[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

LAN Help Thing

Thank you to all who have provided help.

To this point, it's been this:

1) Had the wrong patch cords, got the right ones

2) Direct coupling of two NICs failed to allow traffic; ifconfig's looked good tho.

3) Was asked if the NICs had the 'link'light on, they did not.

4) Was promted to buy a hub or switch. Haven't today, but am pricing models.

5) Changed the ethernet cord from the eth0 card on one host to the eth1 card.  Now i got 'link' lights.

6) The eth1 card is uses an RTL8139 chip, whose driver comes as a module from Realtek.

7) So i compiled the module, it was for a 2.2 kerenel and i use a 2.4, but what the hell.  Had to compile some other module too, a scan-pci.o. Couldn't insmod either of them due _many_ 'unresolved symbols,'

8) Got a driver from Realtek for a 2.4 kernel.  Compiled it.  Tried to load the module with insmod.  Didn't work: unresolved symbol synchronize_irq. %$#@!.

9) So I've got one card (the eth0, a 3Com 3c905B) that plays well with all the other cards including the cable modem (i think), except it won't communicate at all with the pcmcia card in the laptop.  (I read on debian.lists.org where some guy using the same xircom pcmcia/carbus card i'm using said that the linux driver is only good to 10M/sec, and the pci card i have is only good for 100M/s.)  

   The other two cards (eth1 and eth2) are both Realtek spitballs that I've given up on.  I bought them because the retail box says they work with Linux, drivers included.  Bah.  After ~4 hours of looking at mailing list postings i don't see anyone who's got these Realtek cards working with ANY driver, except one guy using potato, and his email adress was blocked out.  I've already went thru the steps he says to go thru anyway.

10) My next step is to print out what pci cards are supported _in_the_kernel_source_ and hope the computer store has two of those, because i lost my reciept for the Realteks.  

11) I am also having alot more trouble just getting the cable 'modem' to work under linux than i thought i would've, however i have not done much serious troubleshooting, just reading outdated (read: potato-level) DHCP howtos.  I plan on calling/emailing the cable company regarding this, it's a longshot but might work out.  I hope i'm invited to use this mailing list in order to get this particular problem solved, although it's not directly a laptop issue.


To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: