[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing programs from a none-debian CD or from the Harddisk

Hello Debian runners!
I hav some problems installing programs to my Debian 2.2r4. (Accept the ones on the 3 installation CDs, which -as the only method succeded for me. But the programs I want are not there!). I have tried EVERYTHING I can think of, but nothing seems to work. (I even have used a "APT HOWTO" by some N. Silva, and some FAQ about it). Perhaps some of you know whats wrong. Here is what I did:
1. -I made the directory "debs" in root/, and copied every .deb file into it.
    -Then I (with touch) made a override file, simply naming it "override". (and with nothing in it, the HOWTO said this should be OK)
    -Then i tipped: dpkg-scanpackages debs override | gzip > debs/packages.gz
    -So far so well, the machine gave me the right number of files being read, so I suppose it did what its supposed to. In the sources.list I added: deb file:/root debs/ And I commented out the installation CDs path. Ï even tried with, and  tried without the "debs" in the beginning. No matter, everything gave:
    - Then I tipped: apt-get update. And it did not and did not help! (I have tired many times, reading this HOWTO over and over again. It just wont work.
2. Second method: I tried the apt-cdrom add command. (I have to download everythinh through an outbound connection because my is far to slow, then save it on a CD). This wont do, it tells me "this is no Debian CD". (This was with dselect). By the way: How do I prevent the maschine from listing the 4000 packages I have on my CDs, so that I dont have to choose from them again? Or, can I save the choises I have made, so I dont have to go through it agaib?
3. My last unsuccsessfull methos: Installing from sourch code. I did this (as said in the magazine "Linuxformat", that I purchased with a CD and the program I want):
    -tar xjf /cdrom/Desktop/KDE22/packagename.tar.gz (I typed the packagename were this is written). This point only partially worked; my machine wouldnt execute the "j" command, but I managed without it. (tar xf ....).
    -having untared and unarchived the saying files, I changed to the directory where they was (on my harddisk, I even tried beeing on the CD, but nomatter; the same result).("cd packagename")
    -Then i typed ./configure (The CD has a program wich then is to execute). The machine prompted me "QT is missing" and stopped. Perhaps this is the problem. Butr also when I tried the KOffice, and then it missed nothing. I tried the next command:
    -make There everything stopped. "Cant find target it said". And there it is...
Should I write to the magazine, or am I doing something wrong? Or perhaps my downloaded Debian files are to use? Any help wuld be appreciated!
Hope someone could think of something!
Thanks in advance

Reply to: