[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian setup freezes when trying to remove pcmcia

Hi Bart,

I've had some pcmcia releases where my xircom card worked fine, but
most haven't. Different versions of the card are slightly different and
the last I heard the problems hadn't been solved for all the cards yet.
Maybe that's old news and everything is working fine now, but I don't

Since the card is one known to have problems in the past, I'd test it
separately from the road runner network if possible. Figure out how to
kill whatever dhcp client pcmcia starts when the card is inserted and
then use ifconfig to configure the card by hand. Use a crossover cable
to connect to another computer. If the card works ok, then you just need
to figure out how to get dhcp working with roadrunner - maybe it needs
a special hostname or client-identifier to be sent to make the machine
look like a windows machine? If you have a local LUG mailing list,
someone on it could proably tell you if there are any special
requirements if road runner can't. Try putting the card into
promiscuous mode if it doesn't work without it.

If the card doesn't work, then you need to make sure you're doing the
right thing with ifconfig. You'll need a third computer (or at least a
third NIC) to verify that you are setting up the network properly. If
you can get the network working with these systems but not your xircom
card then the problem is probably with the xircom card or software.

I'd start by pinging systems based on ip address. Then you don't have
to get DNS involved in your debug process - well not unless the system
does reverse lookups before responding to pings, but that's unlikely.

I saw some other messages asking about /etc/resolv.conf. I think
dhclient will move the file and write new info there when it
successfully gets an address. Most servers will provide at least the
nameserver you should use in the dhcp config info they send out.

On Tue, Aug 21, 2001 at 06:08:46PM -0400, Bart Szyszka wrote:
>> Check /etc/pcmcia/network and /etc/pcmcia/network.opts. The logic seems
>> a bit involved. For example, pump can be started if $PUMP is true; or
>> $BOOTP is true, but there are no other bootp clients; or either $DHCP or
>> $DHCLIENT is true and there are no other dhcp clients.
> This is getting really frustrating. I've tried pump, dhcp-client, dhcpcd
> (which
> has worked on other computers for this connection) without any luck. I've
> also attempted to add that line to /etc/pcmcia/network to make the card run
> in promisc mode. No luck. Is there anything I can do about /etc/resolv.conf
> ?
> I noticed that the other config files point to that yet there is nothing in
> /etc/resolv.conf . That file is empty. Maybe that's the problem? I've tried
> running all these clients manually and that hasn't helped anything either.
> Is
> there anyone here on a RoadRunner connection who has gotten their
> Inspiron 8000 working with the Xircom CardBus Ethernet II 10/100? Could
> this have something to do with RoadRunner itself? This Sunday I'll be moving
> to one of my unversity's residence halls and will have an ethernet
> connection
> there. Maybe it'll work then, but I was hoping I would be able to setup
> everything
> on this new laptop for Linux before I left.
> - Bart

Lee Bradshaw                 lee@sectionIV.com
Texas Instruments            bradshaw@ti.com

Reply to: