[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.7 kernel problem

hi zoltan,

it seems you compiled your ide-drivers as modules.  the kernel cries for
a module servicing block devices with major number 3.  these are for the
first mfm, rll and ide hard disk/cd-rom interface (from

compile the ide-drivers into the kernel and you should be fine.

happy hacking,


On Wed, Aug 08, 2001 at 05:57:05PM +0100 or thereabouts, Zoltan Nagy wrote:
> Hi,
> I use the unstable distribution on a Dell Inspiron 4000 laptop. The recompiled
> 2.4.7 kernel doesn't work. At the boot time it can't mount the root file
> system and the booting process stops with the following message:
> request_module[block-major-3]: Root fs not mounted
> VFS: Cannot open root device "hda6" or 03:06
> Plese append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on 03:06
> My root device is the hda6. I can boot only with the precompiled kernel packages
> the debian distribution and an old 2.4.5 kernel which was compiled few weeks ago.
> Regards,
>  Zoltan
> --  
> To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: