[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

loadlin hangs after loading kernel and root image (on C1VN)

You wrote:

> To: c1-forum@frijoles.com, debian-laptop@lists.debian.org 
> Subject: loadlin hangs after loading kernel and root image 
> From: Ookhoi <ookhoiKILLALLSPAMMERS@dds.nl> 
> Date: Thu, 11 Jan 2001 08:21:18 +0100 
> --------------------------------------------------------------------------------
> Hi!
> With the help of Maarten Slaets I managed to let winme have the option
> to boot into dos. So now loadlin works, but it hangs after loading the
> kernel and root image. 
> If I type (from the install.bat): 
> loadlin linux root=/dev/ram initrd=root.bin disksize=1.44
> it says that it loads the kernel and the root image, then it clears the
> screen and the only thing left is a blinking cursor. The system hangs
> rock solid.
> I don't know how loadlin works (first time, use floppies al the time but
> I don't have a floppy drive on this one), but I guess it is a kernel
> problem, because loadlin only prints the dots for the loading of the
> kernel and the root image, but does not give any output you see with a
> normal linux boot. I've tried several kernels from debian (ao idepci)
> and the latest 2.2 and 2.4 homebuilt and with different configs, but
> nothing changed.  I've also tried different root images (idepci).
> Can it also be a dos problem because it is hacked winme?
> The system is a sony vaio c1ve (european c1vn) with the transmeta crusoe
> processor. 
> The distribution is debian.
> Tia for any info!
> 		Ookhoi

Hello there,
I've got the same problem at the moment. Did that winme1.3 patch,
(from http://www.geocities.com/mfd4life_2000/)
wiped out the d drive and extended partition, got the base debian
stuff ready, and used the loadlin command:
loadlin linux root=/dev/ram initrd=root.bin disksize=1.44

I thought, hey, yeah, loadlin rocks! Who needs a cdrom drive or
a floppy drive for installation? But....

I'm experiencing exactly the same hang. Trying vga=ask at the end makes it
ask for video modes, (and you can even get it to do a video mode change),
but it freezes rock solid (blinking cursor) right after, and you have to
reboot by pressing the button for 4 secs. Like you I've
been trying smaller kernels (reading the loadlin docs made me wonder
if the kernel had to be smaller to fit in to the crusoe way of handling
RAM), but I'm stumped now.

I'm wondering if it is the L2 cache hardware problem which
some crusoe 600 chips have problems with (it affects their
ability to restore MS windows sometimes).

Did you manage to figure it out in the end? I'm wondering if xosl
is the One True Way for installs on the picbook now.


Reply to: