[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Runing cardctl from a normal account


I am using Debain Potato (rel 0) on a Sony Vaio PCG-C1F laptop. 

I would like to be able to run:

	cardctl eject | cardctl scheme | cardctl insert

from a normal user account. I have tried using the following command,
which prompts for roots password and then should run the command:

	su - root -c cardctl eject

This results in an error as shown in the output below:

sjrowe@vaio-sr:~$ su - root -c cardctl eject
usage: cardctl command [socket #]
    or cardctl [-c configpath] [-f scheme] [-s stab] scheme [name]
    commands: status config ident suspend resume reset eject insert

The command works ok with other utilities where an argument is being
passed, so I am not sure why it fails with cardctl?

I have tried it specifying the socket number too -just in case!

Any suggestions, alternative methods (sudo I suppose??) would be great.

Thanks for you help


Simon Rowe
email:  sjrowe@ewor.co.uk
www:  http://www.ewor.co.uk/

Reply to: