[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: update: PCMCIA "make all" errors

Donnie Jones <donniejones18@yahoo.com> writes:
Hey all,

Thanks again for your help.... yet, I have returned,
but with, I believe to be, a simpler problem.

I installed kernel 2.2.17 using the make-kpkg as you
suggested, and it worked out just fine.  The source
for the pcmcia compiled and the module for my IBM
EtherJet card is shown when I do "lsmod."  But, for
some reason when I do "ifconfig," eth0 is not listed. I did "ifconfig eth0 up" and from there eth0 is shown
when doing "ifconfig."  Even though the "ifconfig" is
now showing the eth0 I attempt to ping an IP address
and it tells me that the network is unreachable.

I had what appears to be the same problem with
my IBM EtherJet card on a Thinkpad A21p.
The card was able to send packets, but did not
recognise incoming data. After much searching on
the net, I found the suggestion to do
"ifconfig eth0 promisc", and this solved the problem.

To get this working automatically, I tinkered a bit
with the config files. Being new to Linux, I'm sure
that there are prettier ways, but these modifications
at least worked for me. :-)

In /etc/network/interfaces:
iface eth0 inet dhcp
pre-up /sbin/ifconfig -i eth0 promisc
up /sbin/ifconfig -i eth0 promisc

To get the pump-dhcp client working, in
/etc/pcmcia/network: (not /etc/pcmcia/network.opts)
if is_true $PUMP ; then
/sbin/ifconfig -i $DEVICE promisc
sleep 1
/sbin/pump -i $DEVICE > /dev/null
sleep 1
/sbin/ifconfig -i $DEVICE promisc
elif ...

Hoping this will be of some help,

Finn Lindgren (finn@maths.lth.se)

Reply to: