[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: _PCMCIA_"make_all"_errors

On Thu, 22 Feb 2001, Lee Bradshaw wrote:

> On Thu, Feb 22, 2001 at 08:09:29AM -0800, Donnie Jones wrote:
> >> > 	Following the pcmcia-howto I first did "make
> >> > configure" on the pcmcia source and use the
> >> defaults,
> >> > and that went fine.  Next I did "make all" in the
> >> > process of doing this I recieve and error and the
> >> > compiling halts.
> >> 
> > 
> > I did that as you said and I still received the same
> > error when trying "make all." 
> > 
> > Any other ideas?
> Try installing kernel-package and using the make-kpkg command.
> Documentation is available in /usr/share/doc/kernel-package/README.gz
> and /usr/share/kernel-package/README.modules (adds info for compiling
> modules like pcmcia to the main instructions.)

It won't help though I recommend using make-kpkg. The problem is that the
modules stuff has changed a lot since 2.2.17 an there are ifdef's that
look for kernel versions > 1.3.something. They won't match version 2.2.18
though they should.

take a look at the file
and search for the string "define init_waitqueue_head" you should find it
enclosed in ifdef's like the following:

#define init_waitqueue_head(p)  (*(p) = NULL)
#define init_waitqueue_head(p)  init_waitqueue(p)
typedef struct wait_queue *wait_queue_head_t;

When I compiled some third party drivers I had to tweak some of those
ifdef's though they should be OK in the pcmcia-source package. Mine is
Version: 3.1.22-0.1potato


Manfred Wassmann
PGP and GnuPG public keys available at http://germany.keyserver.net
PGP: 24B81049 Fingerprint: D7 10 EE 2B 74 16 C0 64  B4 5F BA B2 90 29 3D AF
GPG: 6B299971 Fingerprint: A598 A41F 57A3 5D69 83D2  8027 1274 F8CD 6B29 9971
 +++  I18N ?  For international language set LANG=POSIX  +++

Reply to: