[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Modem not working in Linksys PCMCIA Ethernet + modem combo


I have the Linksys Ethernet + modem PCMCIA card (PCMLM56) and can't get the
modem to work (the Ethernet worked right after potato install). The system
is Toshiba 2545 XCDT. In Winblowz, the modem is COM2, so I assumed it would
be /dev/ttyS1. I have tried the advice from this list, commenting out the
Token Ring line in /etc/pcmcia/config.opts but it did not help.

wvdialconf for some reason scans /dev/ttyS0 and /dev/ttyS3, even though the
wvdial.conf contains /dev/ttyS1.  setserial /dev/ttyS1 reports port 0x12f8
irq 3 UART 8250. /proc/interrupts lists only pcnet_cs for irq 3, so I
thought maybe there was an IRQ conflict and tried to setserial /dev/ttyS1
to different (available) IRQ with no result.

I guess one problem is that the modem is silent, so I can't even hear it
dialing. But I expected it to at least flash when I do echo "ATZ" >

Thanks for your help and sorry if I'm missing something obvious.


Reply to: