[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: multiple kernels fandango.

I bothered to mention it, hate to reply to myself, but I did find the

I suppose I'll have to file it as a bug for modutils package, that the
obvious backup files <foo>.dpkg-old really ought to be moved to some other
directory, or they'll haunt your poor little computer's dreams. Contrariwise,
if update-modules' automagical creation of /etc/modules.conf would have
skipped that old cruft... it would have been no problem...

To explain more clearly - in slink, the paths to look for modules had to
be stated somewhat explicitly, though it could at least cheat by using
`uname -r` or `kernelversion` in the paths.  In the new one, you don't have
to mention these things at all.  But also in the old one, a path was mentioned
which was above all the kernels - and I guess in the old way, it did not
recurse, and under the new conditions it did.  What a mess.

Anyways, have a better day than me :)

* Heather Stern * star@ many places...

> Okay, I know oyu guys are going to laugh, but we all have our bad days.
> Maybe I should take the world in smaller chunks than by running 
> 	apt-get dist-upgrade
> Anyways, most of the things I thought would be sneaky and evil weren't.
> (Thanks, of course, to the maintainers :> for their recommends: being on
> straight.)  But, I am the sort of person who keeps about 4 different kernels
> around.  That usually being
> 	a debian normal image out of the kits
> 	a locally compiled current kernel for normal use
> 	a bleeding edge 2.2 kernel
> 	whichever 2.4 kernel I've decided to inflict on myself lately.
> Anyways now that 2.4 is actually approaching usable I'm going to be 
> switching a lot more than I used to.  The thing that's really getting me 
> tho, 2.4pre's aside, is that depmod is driving me crazy.
> I have a 2.2.16 kernel with USB support as my day to day kernel.  I switch
> to my bleeding edge 2.2 kernel and depmod -a still reaches for 2.2.16.  Of
> course I tried reading the notes in /usr/share/doc/modutils, but they're 
> useless for this.  I tried doing an strace to see if I could determine where
> it was learning 2.2.16, since /boot/System.map is a symlink the the new map,
> /boot/vmlinuz is a symlink to the new kernel, and uname -r properly reports.
> I'd say I'm sure I'm missing something simple, and I hope so, but I'm feeling
> rather cynical about it at the moment.  Attempts to use -F to tell it to use
> the correct system map still must be checking against 2.2.16's modules tho,
> because when I do that, only 3 of them complain about missing symbols instead 
> of darn near all of them.  If it were looking properly at this morning's 
> 2.2.18pre21 it might not be missing any.
> doctors make the worst patients :(  Any ideas for hackery suitable to make
> it stop memorizing the last kernel it was on are highly welcomed.  And if 
> I find or hack together a working answer first, I'll let you know.  But 
> any advice towards enough to make a more useful bug report than "upgraded,
> now it doesn't work.  noisily." will be greatly welcomed.
> I'm kind of afraid to recompile card services until I'm sure the parts 
> will be probed orrectly.
> * Heather Stern * star@ many places...
> --  
> To UNSUBSCRIBE, email to debian-laptop-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: