[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IBM Thinkpad 770 - Mouse "goes crazy" in X

Iohan wrote:
> I've looked at the Linux Laptops HOWTOs and various webpages but I haven't
> found a solution.
> My X 3.3.6 runs fine, but the mouse just jumps around uncontrollably.  I've
> tried just the built-in trackpoint, and I've tried plugging in a regular MS
> Intellimouse in the PS/2 port.  Same problem.

Presumably you have a Savage/IX /MX video card (My T20 has this one), did you
use this patched version of X-server instead of the one from the original debian


It should work.

> I've tried modifying the XF86Config with different protocols - "PS/2",
> "Microsoft", and "Intellimouse".
> I've tried modifying the device in XF86Config - "/dev/psaux", "/dev/mouse",
> "/dev/gpmdata"
> I've tried with and without "Emulate3Buttons"

Setting the device to /dev/psaux works fine for my T20. 
And maybe you know this already, /dev/mouse is normally a symbolic link. 

> The mouse works fine in text mode.  But when I start X, it is uncontrollable.

In this connection, I'd like to ask for some information. After I upgraded to
I lost my gpm. Apparently /dev/gpmctl gone missing and I was not able to get in
I was told that it may be a pipe but creating it manually doesn't work. Anyone
has any such experience or the answer?


Reply to: