[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Driver for _ISA_ Lucent winmodem?

On Tue, 27 Jun 2000 20:14:17 Nicola Bernardelli wrote:
> Ciao Francesco,
> Thanks a lot for replying. After you told me that the driver _does_ work for
> ISA pnp version of the modem, I concentrated on looking for what process
could be
> using the resource and tried hiding the ttyS3 device and even avoiding isapnp
> the setup. Well... finally I got it, I just had to uncomment one further line
in my
> isapnp.conf file,
> (IO 1 (SIZE 8) (BASE 0x0100))
> that's all. Afterwards I've been making some tests.
> Sometimes the driver shows a lot of hex flags and complains "Aieee" trying to
> don't remember what (will try to reproduce it if anybody wants a true report)
> it just freezes the whole system with need to power down (this laptop doesn't
> an hardware reset), it seems as removing the module - eventually sleeping 1
sec -
> and reinstalling the module is a good thing before trying a new connection...
but I
> haven't been able to isolate a serie of actions that causes the problem yet.
> Anyway, I could connect to one of the ISPs I have access to here in Paris
> could at last pop my e-mail accounts with a single popclient call as I used
to on
> my Linux desktop in Italy, before getting stucked to win stuff on this
>which means tweakling with the mouse to manually change Netscape's preferences
> it just to pop one account at a time, phhhhhhhh). I've been using wvdial as
my ppp
>setup is not fine yet (and pppd complains about secrets it doesn't find... not
> permission problem as I was firing as root... wvdial itself stored the
> well that's another problem, I'll just see the docs).
>The best connection I get is
>     CONNECT 50666 V42bis
> (but sometimes tonight on the same ISP I got 48000 or little more, sometimes
> actually it was around 32000).
 >As in your other system, the further setup you suggested via setserial seems
 >absolutely uninfluent on the results (unless I add the flag spd_hi, which
makes the
 >connection speed stay at just 14400, always V42bis).
 >If I just ask what's the setup without imposing any parameter:
> # setserial /dev/ttyS14
> /dev/ttyS14, UART: undefined, Port: 0x0100, IRQ: 3
 >and appearently it works the same.
 >I've been running kernel 2.2.14.
Just posting this in case someone else need it. In my previous post, I forgot
 to mention that I'm running 2.2.13 with the following option enabled :
   Character devices --> Support more than 4 serial ports
   Character devices --> Support for sharing serial interrupts
 I'm not sure if these options matter. In my quest for making the modem work,
 enabled them after having seen THIS MESSAGE from the  modem module :
    " Lucent Modem driver version with MANY_PORTS     MULTIPORT
 SHARE_IRQ enabled"
 Anyway, I use the PCI Lucent modem every day and it works flawlessy. The ISA
 version worked the few times I used it, but I mostly use my laptop in a
 environment, so I can't say how good it works.

Reply to: