[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: BUG?! no pcmcia ethernet on battery power

dfparsons> Do we have a utility yet for fiddling with the Toshiba
dfparsons> bios?  

sorry i don't.  i did just as you did, by rebooting and using
the bios configuration settings.

dfparsons> ...you're right!  The PCCard option in the bios had been
dfparsons> set to "auto-select", choosing between "PCIC compatible"
dfparsons> and "Cardbus/16bit".  If I set the option to "PCIC
dfparsons> compatible", card reinsert works fine under battery power.

glad to hear that things are working for you ;-)

dfparsons> I guess that means there's some problem with the cardbus
dfparsons> code in pcmcia-cs under battery power, so I should problem
dfparsons> submit a report about that.  

yeah, i think submitting a report for that would be good.

dfparsons> Lucky for me my card is pcmcia, not cardbus, so I can
dfparsons> tolerate turning off cardbus support in the bios.


speaking of cardbus, i tried to get a 3com 575 cardbus ethernet card
working the other day and although i get two high-pitched beeps after
insertion and i see eth0 under ifconfig, i haven't been able to get it
to work.  looking in /var/log/daemon.log doesn't shed any light on the
matter either.  the pcmcia howto wasn't helpful in this respect

i searched the archives of this list and noticed that some people have
had problems and other people don't seem to.

very puzzling.

to digress even further, does anyone know how to get fsck to postpone
running until next boot?  what happens to me is that i'll be in a hurry
to get at some of the data on my laptop, so i'll turn it on, but
while booting, i'll be unlucky enough to get stuck waiting for
fsck to check one of my partitions.  i have no problems w/ running fsck,
but i'd rather be able to postpone it until i have more time ;-)

> there's also section 3.5 of the pcmcia howto concerning anonymous
> memory cards, but i presume you've looked there already.

dfparsons> They had a couple of tips there, about narrowing the memory
dfparsons> range or fiddling with the timing, but none of it helped.
dfparsons> Either you need greater expertise to get just the right
dfparsons> sort of fiddling, or those tips only apply if you're
dfparsons> *always* getting the "anonymous memory" problem, rather
dfparsons> than only with battery power on reinsert.

i think if you happen to have the settings that the m$ os (which might
be on your machine [or may have been on your machine]) uses, an idea
is to try the settings that might have worked for that os.

Reply to: