[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pxeboot not working for knoppix 7.2.0

On 2/19/14 6:49 PM, Klaus Knopper wrote:
Hello Ryan,

On Wed, Feb 19, 2014 at 02:13:04PM -0500, Ryan Chase wrote:
On 2/18/14 10:44 PM, Ryan Chase wrote:
On 2/18/14, 9:58 PM, Klaus Knopper wrote:

On 18. Februar 2014 23:23:59 MEZ, Ryan Chase <rchase@cs.vt.edu> wrote:
I cannot pxeboot knoppix 7.2.0 from either an existing pxe server
installation or by booting a knoppix CD on a computer and running
terminal services.  On the client, it fails to probe for any network
card and insert the appropriate kernel module.  This behavior exists
both the CD and DVD versions.
    I can, however, pxeboot knoppix 7.0.5 successfully using the same
machines in the same environment.

Is this a known issue?


If you booted the server with the 64bit kernel (knoppix64), you have to boot the clients with the 64bit kernel as well, otherwise the 64bit modules won't match.

This will be changed in the next release, so the clients will allways be 32bit regardless of the servers kernel type.


  I haven't attempted to boot anything into 64bit mode. I boot the server
>from the knoppix DVD, and configure knoppix terminal server. Then
attempt to boot the client. The client gets an ip, starts the tftp
process, and then fails to probe for any video card ultimately dropping
to a minimal shell.

Wait... You wrote "network card" earlier, but here you say "video card".
I'm not sure if I'm thinking of the right problem here.

If it's "network card", your computers network card may be unsupported
or not checked in the list provided by the terminalserver, or some
dependency module is missing.

Can you type "lsmod" in the minimal shell, just to see if any modules
are loaded? Do you know the correct module name for your network card?
All modules integrated in the initrd are located under /modules, with
numbers 00_ for dependencies and the real module name for the network
card, so you can try if the module loads manually.

Also, the output of "dmesg" can help.

I'll try the 64bit mode tomorrow to see if I get the
same results.

Probably yes. Just stay in 32bit mode for server and clients for now, to
make sure it's not a bitness problem.


Sorry, yes, I meant "network card". The module for the network card doesn't seem to load. I've tried this on clients with a broadcom card needing tg3 and an intel card needing e1000e. When I manually try to load the module, I get the following:

tg3: Unknown symbol ptp_clock_index (err 0)
tg3: Unknown symbol ptp_clock_register (err 0)
tg3: Unknown symbol ptp_clock_unregister (err 0)
insmod: cannot insert 'tg3.ko': Unknown symbol in module (-1): No such file or directory

I get the exact same error message when I try to use the intel based client only, replace "tg3" with "e1000e". I'm working with the 32bit version only.

I don't think it's a matter of unsupported network cards as I can boot 7.0.5 clients just fine using a 7.0.5 terminal server.

Reply to: