[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Knoppix V4.02 and V5.01 under VMPlayer and Virtual HD's



In attempting to create a virtual machine I have run into a snag. 
 
Unable to access the virtual HD for writing, I CAN HOWEVER 
use the virtual HD to save a persistent home and/or settings via the 
Knoppix menu. 
 
You can reference:
http://www.vmware.com/community/thread.jspa?threadID=54055&tstart=0


If I do a Run Command and run Konq as root, I can write (make a new folder, text file etc.) to the 
virtual HD now, so this is a obvisouly permissions issue. 
 
I've tried various things like umount and mount the hd in a root 
konsole with various options, same thing. ACCESS DENIED. 
 
I've tried adding umask=000 to the /etc/fstab, still ACCESS DENIED. 
 
Any one have any ideas on how to make the virtual HD writeable for
the knoppix user or a user created on HD install to the virtual HD? ?

Using the icon on the desktop to change modes, while it says its "writeable" still gives access denied for any user other than root.
 
Thanks in advance.
 
/etc/fstab
/etc/fstab/ 
noppix@1[knoppix]$  cat /etc/fstab 
/proc /proc proc defaults 0 0 
/sys /sys sysfs noauto 0 0 
/dev/pts /dev/pts devpts mode=0622 0 0 
/dev/fd0 /media/fd0 auto user,noauto,exec,umask=000 0 0 
/dev/cdrom /media/cdrom auto user,noauto,exec,ro 0 0 
/dev/hdc /media/hdc auto users,noauto,exec,ro 0 0 
# Added by KNOPPIX 
/dev/hda1 /media/hda1 ext3 noauto,users,exec 0 0 
# Added by KNOPPIX 
/dev/hda2 none swap defaults 0 0 
knoppix@1[knoppix]$  
 
knoppix@0[knoppix]$  mount
/dev/root on / type ext2 (rw)
/ramdisk on /ramdisk type tmpfs (rw,size=195204k)
/UNIONFS on /UNIONFS type unionfs
(rw,dirs=/ramdisk=rw:/KNOPPIX=ro,delete=whiteout)
/dev/hdc on /cdrom type iso9660 (ro)
/dev/cloop on /KNOPPIX type iso9660 (ro)
/UNIONFS/dev/pts on /UNIONFS/dev/pts type devpts (rw)
/proc/bus/usb on /proc/bus/usb type usbfs (rw,devmode=0666)
automount(pid2033) on /mnt/auto type autofs
(rw,fd=4,pgrp=2033,minproto=2,maxproto=4)
/UNIONFS/dev/hda1 on /mnt/hda1 type ext3
(rw,nosuid,nodev,user=knoppix)
knoppix@0[knoppix]$  
 


 

Reply to: