[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#615609: [loongson-dev] Bug#615609: linux-image-2.6.37-1-loongson-2: Lemote mini-pc with linux-image-2.6.37-1-loongson-2 doesn't support external usb NIC (TU2-ET100)



> 1) try this NIC with another machine (non-Loongson);

Done, it works well on x86_32 and x86_64 (both intel).

I've also tried:

acpi=noirq
usbcore.autosuspend=-1

Which in the past have been able to solve other serial usb issues, but
none worked out...

> 2) try another kind of NIC on this machine (e.g. there are MosChip mcs7830
> based USB NICs which also support true USB 2.0 speeds, or if USB 1.1 with 12
> mbit is enough, then Davicom dm9601 can be an option).

I'll look for them.  I acquired another one to try, but at the end it
was based upon the same chipset, so also the same driver, so it didn't
help.  I'll look in the web...

>
> As for trying different module parameters you mentioned earlier, usbnet and
> asix do not have any tunables, but ehci_hcd does have some, you can check
> them out with "sudo modinfo ehci_hcd".

Thanks a lot Roman, I'll investigate as soon as possible.  I'd like a
work around before going to buy something else, so this will be my
first step, :-)

So far no luck, but I'll keep trying, and if anyone gets to find
something, please let me know...

Javier.



Reply to: