[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#604096: Bug#601341: Bug#602418: #601341, #602418 and #604096 seem to be duplicates

On Tue, Dec 07, 2010 at 11:49:14AM +0000, Ian Campbell wrote:
> On Mon, 2010-12-06 at 19:27 -0500, Konrad Rzeszutek Wilk wrote:
> > >  a) Fix the GART/AGP backend (so drivers/char/agp/*.c) so they use the PCI API.
> > >    Only the i915 and higher are using the PCI API and I've some of the older
> > >    boxes with i860 so can actually test it.
> > 
> > I've posted patches to address this (https://lkml.org/lkml/2010/12/6/480)
> > and Dave question is "why anyone cares about AGP in 2010."
> > 
> > I was wondering if any folks could comment?
> His general principle of fixing the modern stuff first and then working
> backwards until nobody is complaining any more seems pretty sane to me.

> Is the series at https://lkml.org/lkml/2010/12/6/516  sufficient in its
> own right to make Nouveau and ATI work or is more needed? What about NV?

Both Nouveau and ATI (PCIe) look to work. I did light testing (ATI ES1000,
Radeon 3450, Nvidia 65.. something) and will need to do some more
aggressive ones. Oh, and Intel GTT seems to work without any of these
patches - but I've only tested it on a machine with 4GB so I need to add
more memory to make sure.

> More generally if we were to take the series from
> https://lkml.org/lkml/2010/12/6/516 but not the series from
> https://lkml.org/lkml/2010/12/6/480 which sets of cards would we be
> including/excluding support for?

 PCIe = supported
 PCI = not supported
 AGP = not supported.
> Ian.
> -- 
> Ian Campbell
> Current Noise: Mistress - 38
> What's done to children, they will do to society.

Reply to: