[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#505435: linux-2.6: The Build-Depends on kernel-package needs upgrading (leads to FTBFS)

On Thu, Nov 13, 2008 at 12:54:56PM +0100, Bastian Blank wrote:
> On Wed, Nov 12, 2008 at 12:13:35PM +0200, Eric Pozharski wrote:
> >                         Build against 11.0011 (current in testing)
> > succeeds.
> The version in question does not use kernel-package to build i386
> packages. No idea what you do.

I didn't state otherwise.  That's what happened to me:

linux-2.6_2.6.26-5 + kernel-package_11.001-0.1 = success
linux-2.6_2.6.26-8 + kernel-package_11.001-0.1 = FTBFS
linux-2.6_2.6.26-8 + kernel-package_11.0011 = success

Maybe I know nothing about equipment, but lack of
F<build/build_i386_none_486/scripts/Kbuild.include> doesn't seem to me
as hardware problem.  Hence my guess that's a dependencies problem.

I've checked run-time dependencies of 11.001-0.1 and 11.0011 for
B<kernel-package> (to be honest, not before bugreporting) -- they
changed.  But added dependencies seem to be installed anyway and
were/are latest (for testing).

BTW, if B<kernel-package> isn't in use to build C<i386>s, then why it's
not set to C<[!i386]> in I<Build-Depends:> of B<linux-2.6>?

Torvalds' goal for Linux is very simple: World Domination

Reply to: