[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Root on LVM bug

On Wed, Aug 22, 2007 at 08:35:08PM -0400, Adam C Powell IV wrote:
> I recently installed etch on an amd64 box which previously had Fedora.
> It had a small ext2 /boot and large LVM, so I shrunk Fedora's volume and
> made a new one for Debian, where I installed everything.  I included the
> LVM modules in /etc/initramfs-tools/modules .  Then I added the
> following section to /boot/grub/menu.lst :
> title Debian
> 	root (hd0,0)
> 	kernel /vmlinuz-2.6.18-4-amd64 root=/dev/VolGroup00/LogVol02
> 	initrd /initrd.img-2.6.18-4-amd64

known bug see #378332, #402931;
> When I booted, it sat at "Begin: Waiting for root file system..." but
> the Fedora 2.6.11 kernel started right up with otherwise identical
> options (except that it couldn't load the Fedora modules in Debian).
> After a few hours of messing around, on a whim I tried changing the
> root= parameter to /dev/mapper/VolGroup00-LogVol02 , which worked!

this is the real root dev
> So I believe something is wrong with either mount or udev used in the
> initramfs, such that it either doesn't create the /dev/<groupname>
> entries, or can't mount them.  I did a ton of searching and couldn't
> find anything, so I don't think this is a known issue.

no it is not an udev trouble.
so the root arg you were passing is a symlink, it is only created
after vgchange run.
it is an chicken egg trouble, once you pass root=/dev/mapper/vg-lv
it is certain to be an lvm2. unlinke to mdadm we can't enable all
vg as lvm2 is prone to data corruption with empty vg.


Reply to: