[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Root on LVM bug


I recently installed etch on an amd64 box which previously had Fedora.
It had a small ext2 /boot and large LVM, so I shrunk Fedora's volume and
made a new one for Debian, where I installed everything.  I included the
LVM modules in /etc/initramfs-tools/modules .  Then I added the
following section to /boot/grub/menu.lst :

title Debian
	root (hd0,0)
	kernel /vmlinuz-2.6.18-4-amd64 root=/dev/VolGroup00/LogVol02
	initrd /initrd.img-2.6.18-4-amd64

When I booted, it sat at "Begin: Waiting for root file system..." but
the Fedora 2.6.11 kernel started right up with otherwise identical
options (except that it couldn't load the Fedora modules in Debian).

After a few hours of messing around, on a whim I tried changing the
root= parameter to /dev/mapper/VolGroup00-LogVol02 , which worked!

So I believe something is wrong with either mount or udev used in the
initramfs, such that it either doesn't create the /dev/<groupname>
entries, or can't mount them.  I did a ton of searching and couldn't
find anything, so I don't think this is a known issue.

Given that installed Debian and other distros can use both /dev/mapper
and /dev/<groupname>, shouldn't this be supported in the root= parameter
in grub?  Where is the bug, and has it been fixed already in lenny?  If
not, how can I help?

[Please cc me in replies]

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

Welcome to the best software in the world today cafe!

Reply to: