[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#354458: Kernel panic after upgrading initramfs-tools


2006/3/17, maximilian attems <maks@sternwelten.at>:
> the easiest thing for your is to look for your next local debian expert.

I'm afraid that's me :)

> you may have forgotten to install the grub package inside of your chroot.

You explicitly told me to run grub-install from outside the chroot
(so, the Knoppix one), so I didn't do anything else.

> you'll get an chroot from an recent debian etch beta 2 installer,
> which you can boot with "rescue" and there is an reinstall grub
> in the rescue operation menu (which will rerun the grub-install you
> already tried) but not install grub itself that you need to do from the
> chroot

Well, you should have told me then :) I'll try to install grub from the chroot.

> > How can I prevent it in the future?
> always keep 2 linux-images to boot into it,
> initramfs-tools only updates your newest one.

Yeah, but unfortunately, due to my small root partition, I had to
remove the older kernel. I tried to reinstall it, but 2.6.12 had been
removed from etch.

About your next mail: that device command simply isn't available in
the grub commandline that I get. It doesn't exist. Maybe it's too old?
I think it's grub 0.95. According to Knoppix it's 0.95+cvs20040624-17.


PS: http://manuel.msxnet.org/

Reply to: