[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: desktop extremely unresponsive (4.6.5 etc.), strange workaround [solved]

Hi Martin,

thanks very much for looking at it and replying !!

On Wed, 16 Nov 2011 14:45:23 +0100
Martin Steigerwald <Martin@lichtvoll.de> wrote:

> Am Sonntag, 13. November 2011 schrieb Stephan Hachinger:
> > I installed KDE 4.6.5 from debian-desktop.org on squeeze (and actually
> > have replaced it now with a KDE 4.7.3 re-compiled from Ubuntu). 
> > The Plasma deskop is (with 4.6.5 and 4.7.3) extremely slow -- ie I
> > click on the K menu and it freezes for 1min before the K menu appears.
> > This is with and without graphics effects switched on (geforce 8200 w/
> > nvidia driver). I have also tried (w/o change) to switch off the start
> > of all "services at system startup" in the system settings. And of
> > course with a empty .kde in my home, and as normal user or as root.
> > Nothing helped.
> > However, the problem completely disappears when I do not use ksmserver
> > in /usr/bin/startkde, ie I replace
> > 
> > #kwrapper4 ksmserver $KDEWM
> > 
> > by:
> > 
> > kwrapper4 kwin &
> > kwrapper4 plasma-desktop &
> > kwrapper4 krunner &
> > test -n "$ksplash_pid" && kill "$ksplash_pid" 2>/dev/null
> > 
> > I have put the .xsession-errors for the first (original startkde,
> > "bad") and the 2nd (modified startkde, no ksmserver, "ok") case in:

> On a first glance both xsession-errors looked quite simular to me. Are you 
> sure you got the right one for the good case?


> The other things I found:
> - Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoServer: 
> Failed to connect to socket /tmp/dbus-T2YWVptAcv: Verbindungsaufbau 
> abgelehnt
> - Akonadi does not be able to start the MySQL database server... did you 
> install mysql-server-core-5.1 or something like that?

There was a stupid problem: ALL: / ALL: localhost was missing in /etc/hosts.allow. Fixed that. Yet, the situation remained strange: When starting KDE with KDM -> problem gone. With startx (as I normally do) it persisted -- although there was no apparent difference in how the X server was started.

Finally, I decided to upgrade the whole system to testing. This fixed the problem. Sorry that I did not track down the issue further -- would have been interesting but I was running out of time.

Martin, if you want that coffee, get in contact pls :)



Reply to: