[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: keyboard problems after 4.5.1

On Fri, Sep 10, 2010 at 5:20 PM, Andreas Bourges <andy-lists@bourges.de> wrote:
> Hi,
> ...first of all - thank's a lot for providing these packages! Great job and no
> package-related problems during the upgrade from 4.4.5.
> there's just one thing which doesn't work after the uprade: my keyboard
> behaves a bit strange now.
> examples: the left- and up-arrow (separate arrow-keys, not num-pad) doesn't
> work anymore (yes - right- and down-arrows work). The arrow-keys on the num-
> pad work without problems.
> AltGr stopped working, too and somehow I managed to change the keymap
> completely (don't know how this happed, I didn't configure anything on purpose
> - no normal characters worked, I only saw strange ascii-graph chars when
> typing, in all applications kde/non-kde... - reboot helped).
> Any hint on where to look for that? I tried already to adjust the keyboard
> hardware and keymap, but it didn't help.
> Thanks,
> Andy


Since a long time ago, Xorg switched to dynamic device detection
(hotplug, no xorg.conf, etc...). What happens with this is that most
input devices are now handled by the evdev driver instead of the old
keyboard/mouse drivers. Unfortunately, the keyboard mappings that
evdev does for keyboards are not compatible with the ones that the
older keyboard driver used.

Since kde does its own keyboard layout handling, you need to specify a
keyboard model at the same place where you choose the layout. All
models listed are meant to be used with the older keyboard driver, not
with evdev. Instead, there is a special "evdev-driven keyboard" entry
in the keyboard models list, which effectively lets evdev do its own
magic with the keyboard model and does not interfere with it.

So, to solve this problem all you need to do is to go to System
settings -> Input devices -> Keyboard -> Hardware and select "Generic
| evdev-driven keyboard" in the keyboard models list. An Xorg restart
may be needed for the changes to take effect (simply logout and press
Alt+E in kdm, then login again).

This problem and solution also applies to previous KDE versions.


PS: If this used to work for you in 4.4 but not in 4.5, this is
probably because the keyboard layout module was completely rewritten
in 4.5, so it may not have upgraded its configuration correctly.
Indeed, I can see on my system that the listed keyboard model is
"Generic | Generic 104-key PC", which is not what I used to have in
4.4, however, for some reason it doesn't seem to apply this
configuration, so my evdev driven keyboard works fine.

Reply to: