[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Misbehaving Multimedia Keys

For the past few weeks, I have been unable to control Amarok (or any other application for that matter) using the multimedia keys on my laptop. They're recognized - they show up correctly in xev and I can assign actions to, for example, the play button by pressing it in the global shortcut configuration dialog (I've tried both the system settings one and the amarok-specific one). They just don't perform their assigned actions when pressed. I've also tried non-amarok functions such as kmix volume mute and they don't work for that either, so it seems to be something on the system level. Any suggestions how to debug/resolve this? Could this be caused by my previous configuration of these buttons as shortcuts while using the Project Neon amarok-nightly builds (that would explain why the volume up/down and mute buttons work - I never configured those in amarok-nightly)? I've uninstalled that now as it was incompatible with Debian's Amarok 2.* packages, but is it possible that it's previous claim on those global shortcuts remains? In which configuration file does kde store the global shortcut settings? I'm thinking that renaming that and starting over is one potential solution.


Reply to: