[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Translations lost on upgrade to KDE4

On Tue, Jun 02, 2009 at 09:08:30PM +0200, Patrice Pillot wrote:
> Patrice Pillot a écrit :
> > tv.debian@googlemail.com a écrit :
> >> Ana Guerrero wrote:
> >>> On Tue, Jun 02, 2009 at 08:22:36AM +0200, Patrice Pillot wrote:
> >>>> Since I upgraded my squeeze laptop to KDE4 last week, the remaining KDE3
> >>>> applications (e.g. kspread, ...) lost all of the translated strings that
> >>>> they took off from /usr/share/locale/XX/LC_MESSAGES/kdelibs.mo and
> >>>> similar generic kde3 .mo files (kio.mo, ...) since those file has been
> >>>> replaced by kde4 avatars of them. This concerns default menu titles for
> >>>> very common menus ("&File", ...)
> >>>> TIA for any piece of advice,
> >>> install kde-l10n-fr
> >> that's going to work for kde4 apps only, for kde3 you have to backport
> > 
> > I thought about it but what I expect some file conflicts by installing
> > old kde-i18n-**. I'm pretty sure cherrypicking through the *.mo file
> > should be sufficient, shouldn't it ?
> Replying to myself...
> I just tried that, putting lenny's
> /usr/share/locale/fr/LC_MESSAGES/kdelibs.mo alongside squeeze's
> /usr/share/locale/fr/LC_MESSAGES/kdelibs4.mo and it seems it just works
> (et least with kspread which is the application where the localized
> dates and number formatting missed me particularly).
> If there is no objection from the maintainers on this list I will file a
> bug tomorrow against kde-standard - I can't think about a more
> appropriate package since kde-l10n-** packages don't have rdepends at
> all and I don't feel like filing against each and every of those ;-)
File a bug about what?
You have to choose here kde3's translations or kde4's, kde3 and kde4 have been
never been co-installable.

Reply to: