[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE4.2 and keyboard shortcuts

On Wednesday 18 February 2009 20:01:57 Valerio Passini wrote:
> Hi All,
> I have configured several keyboard shortcuts bot none is actually working,
> even the defined from default Volume up and Volume Down with OSD. Is
> anybody else experiencing the same or there is someone with a solution?

Yes, i run into the same problem. So let me sum up what I've tried so far:

starting position:
- kde 4.2 from debian experimental branch
- logitech cordless comfort duo keyboard with multimedia keys

- assigned global shortcuts are not doing there way to the configured 


* to exclude possible sources of trouble I created a new user with a fresh 
user profile
* also I switched the language of this new user to us-en, to exclude 
translation issues
* in these fresh profile the multimedia keys are not working
* so I activated the keyboard layout, an initialized it to "Logitech Cordless 
Desktop iTouch", which I used hundred times before ("setxkbmap -model 
logicd_it -layout de -variant nodeadkeys")
* now the multimedia keys are recognized by kde 4.2, which means, when 
configuring a new custom shortcut under "global keyboard shortcuts" in "system 
settings" the multimedia keys can assigned
* to ensure there is no X problem i run xev, which showed me the normal key 
names like XF86AudioRaiseVolume, XF86AudioLowerVolume, XF86AudioMute ... and 
so on
* under kde these keys seems to get mapped to "Volume Down", "Volume Up", 
"Volume Mute" .. and so on
* when assigning these multimedia keys as a local shortcut, all works well - 
so i think it can't be a problem of keyboard mapping
* when assigning other global shortcuts (e.g. ctrl+alt+pgup to kmix volume up) 
- all is fine
* trying to assign the multimedia keys to other programs then kmix result in 
the same behavior - the keystroke didn't find the way to the application 
(straced checked)
* I'm still using the "legacy" ;-) amarok 1.4.10 under 4.2. The mysterious 
thing: I can assign the multimedia keys to amaroks global shortcuts. And it's 
doing fine. The only difference is, that the shortcut dialog recognizes these 
keys with their well known X-names like XF86AudioMute and so on.

That's all i could find out. Actual I've no further ideas what or which config-
file to check, may be as a lack of knowledge how keystrokes are finding there 
way through the kde message system.

I also posted the above to the kde forum under 
t-26877-2.html. The result was: maybe a bug in khotkeys.

Cheers Andreas

Reply to: