[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error starting second X session after Xorg upgrade

On Tuesday 25 July 2006 21:04, D. Michael 'Silvan' McIntyre wrote:
> On Tuesday 25 July 2006 2:34 pm, D. Michael 'Silvan' McIntyre wrote:
> > It's broken, with no trace in its server's config for how I ever had it
> > set up in the first place.
> >
> > I wonder how that happened?
> Because I'm an idiot.  I was looking at the server, not the terminal.  The
> inittab in question is on the terminal, stupid.  (Which is probably only
> broken because I've reverted to a stock kdmrc on the server, which leaves
> out the necessary options to make it play nice with the terminal.)
> 6:23:respawn:/usr/bin/X11/X :0 vt6 -query my.server
> 7:23:respawn:/usr/bin/X11/X :1 vt7 -query my.server
> 8:23:respawn:/usr/bin/X11/X :2 vt8 -query my.server
> You can leave off the -query bit.
> Of course this realization does nothing to explain why there is no longer
> an entry for tty7 in either of the more recently upgraded boxes' inittabs. 
> Was it never there to start with?  Maybe.  I'm stretched pretty thin
> lately.
> I would expect the above to work if you stick it in your /etc/inittab. 
> Adding a new session to KDM to load KDE out of /opt is another matter i
> haven't really considered.

I tried adding the following lines to /etc/inittab:

7:45:respawn:/usr/bin/X11/X :0 vt7
8:45:respawn:/usr/bin/X11/X :1 vt8

but they just activate X sessions (i.e. nothing is visible except the moire 
pattern shown when X starts up) on VT7 and VT8 - kdm is not activated.

I tried again to modify kdmrc to make it work on VT7 and VT8, and managed to 
get the login screen to appear on both, but on VT8, .xsession-errors shows 
that when I try to log in, it attempts to run the KDE session on display :0 
rather than the expected :1. Any ideas on how to fix this?

David Jarvie

Reply to: