[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kde 3.4.1 and libglu1-xorg

I wonder. Nobody having trouble with libglu1-xorg that replaces xlibmesa-glu?

Indeed, I already ran kde 3.4.1. Then did an 'apt-get -t unstable dist-upgrade'
that removed a lot of kde. Fine. I'll reinstall it with experimental, did I say.
But I had to force a lot of packages mainly because of what follows. This is where
I am now, with kde 3.4.1 reinstalled via dpkg -i --force (see the apt output below to
understand why), but I cannot do a [dist-]upgrade anymore:

% apt-get -t experimental install kcontrol
Reading package lists... Done
Building dependency tree... Done
kcontrol is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  kcontrol: Depends: xlibmesa-glu but it is not going to be installed or
  kscreensaver: Depends: xlibmesa-glu but it is not going to be installed or
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


% dpkg-query -l libglu1-xorg | grep ii
ii  libglu1-xorg   6.8.2.dfsg.1-1 Mesa OpenGL utility library [X.Org]

and libglu1-xorg, dixit apt-cache show:

Replaces: libglu1c2, libglu1, libutahglx1, mesag3 (<< 5.0.0-1), xlibmesa3 (<< 4.2.1-5), xlibmesa3-glu, xlibmesa-glu

What am I doing wrong? Could there be a deficiency in apt dependency resolution? Or my deficiency -; !

Thanks, Cheers, JD.

Jean-Damien Durand CERN/IT/FIO/DS - Geneva, Switzerland
PGP: http://home.cern.ch/~jdurand/public_key.asc
CERN CA: http://cern.ch/service-grid-ca/crt/root_crt.html
WWW: http://home.cern.ch/~jdurand

Attachment: smime.p7s
Description: S/MIME cryptographic signature

Reply to: