[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing 3.4.0 killed my -dev environment



On April 15, 2005 02:34 am, Silvan wrote:
> On Wednesday 13 April 2005 09:34 pm, Stephen Cormier wrote:
> > Try apt-get install libarts1-dev=1.4.0-0pre2
> > kdelibs4-dev=4:3.4.0-0pre3 .... with all the other packages you
> > list on the line at the same time and it should work.
>
> I still can't resolve it.  I finally wound up with this:
>
> #apt-get install libarts1-dev=1.4.0-0pre2 kdelibs4-dev=4:3.4.0-0pre3
> libxrender-dev libopenexr-dev libqt3-mt-dev xlibmesa-glu-dev
> xlibmesa-gl-dev xlibs-static-dev libxrandr-dev libxmu-dev libx11-dev
> libxt-dev libxft-dev libxcursor-dev libx11-dev=4.3.0.dfsg.1-12.0.1
> [...]
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>   kdelibs4-dev: Depends: kdelibs4 (= 4:3.4.0-0pre3) but it is not
> going to be installed
>                 Depends: kdelibs-bin (= 4:3.4.0-0pre3) but it is not
> going to be installed
>   libx11-dev: Depends: libx11-6 (= 4.3.0.dfsg.1-12.0.1) but 6.8.2-10
> is to be installed
> E: Broken packages

Add kdelibs4=4:3.4.0-0pre3 kdelibs-bin=4:3.4.0-0pre3 
libx11-6=4.3.0.dfsg.1-12.0.1 to the line and see what it does. Also you 
may want to remove the line for the X.org packages you have in your 
sources.list file and apt-get update again unless of course you want to 
upgrade your Xserver to it. Even then it should still install the 
packages eventually with enough tweaking of the line with the correct 
version = on the end of the package name(s), I have all the -dev 
libraries for KDE 3.4 installed along with the X.org server here. 

Stephen

-- 
Debian the choice of a GNU generation.

GPG Public Key: http://users.eastlink.ca/~stephencormier/publickey.asc

Attachment: pgpw3gtBPgh7O.pgp
Description: PGP signature


Reply to: