[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing 3.4.0 killed my -dev environment



On April 13, 2005 09:35 pm, Silvan wrote:
> On a whim, I grabbed the Alioth packages and gave the new KDE a
> whirl.
>
> I wiped out my development environment in so doing.  The dist-upgrade
> took down a huge number of -dev packages.  It looked like it was
> going to balance out trading this for that and come out OK in the
> end, so I went ahead and did it anyway.  I probably shouldn't have.
>
> At this point I'm stuck trying to get kdelibs4-dev reinstalled.  It
> won't go because libqt3-mt-dev is uninstallable.  This, in turn, is
> uninstallable because of a tangle of broken X-related dependencies. 
> It's a real mess.
>
> I tried adding experimental to the brew, but it didn't help.  I'm
> pretty much stuck at this point, since I can't dist-upgrade back.  I
> could restore yesterday's backup, but I prefer moving forward.
>
> It looks like X switched from XFree86 to X.Org, and it also looks
> like QT has switched from libqt3-mt to libqt3c102-mt.  However,
> libqt3-mt-dev >= 3.3.3 is a dependency of the Alioth kdelibs4-dev,
> and there's no libqt3c102-mt-dev either.
>
> The following packages have unmet dependencies:
>   kdelibs4-dev: Depends: libarts1-dev (>= 1.4.0) but it is not going
> to be installed
>                 Depends: libopenexr-dev (>= 1.2.1) but it is not
> going to be installed
>                 Depends: libqt3-mt-dev (>= 3.3.3) but it is not going
> to be installed
>                 Depends: libxrender-dev but it is not going to be
> installed
>
>
>
> And it's not installable:
>
> The following packages have unmet dependencies:
>   libqt3-mt-dev: Depends: xlibs-static-dev (>= 4.3.0.dfsg.1-4) but it
> is not going to be installed
>                  Depends: libxrandr-dev (>= 4.3.0.dfsg.1-4) but it is
> not going to be installed
>                  Depends: libxmu-dev (>= 4.3.0.dfsg.1-4) but it is
> not going to be installed
>                  Depends: libx11-dev (>= 4.3.0.dfsg.1-4) but it is
> not going to be installed
>                  Depends: libxt-dev (>= 4.3.0.dfsg.1-4) but it is not
> going to be installed
>                  Depends: xlibmesa-gl-dev but it is not going to be
> installed or
>                           libgl-dev
>                  Depends: xlibmesa-glu-dev but it is not going to be
> installed or
>                           libglu1-mesa-dev but it is not going to be
> installed or
>                           libglu-dev
>                  Depends: libxft-dev but it is not going to be
> installed Depends: libxrender-dev but it is not going to be installed
> Depends: libxcursor-dev but it is not going to be installed
>
>
> I can't install the other kdelibs4-dev dependencies either.  More X
> stuff: #apt-get install libarts1-dev libopenexr-dev libxrender-dev
> [...]
> The following packages have unmet dependencies:
>   libarts1-dev: Depends: libqt3-mt-dev (>= 3.3.3) but it is not going
> to be installed
>   libopenexr-dev: Depends: xlibmesa-gl-dev but it is not going to be
> installed or
>                            libgl-dev
>                   Depends: xlibmesa-glu-dev but it is not going to be
> installed or
>                            libglu-dev
>   libxrender-dev: Depends: libx11-dev but it is not going to be
> installed


Try apt-get install libarts1-dev=1.4.0-0pre2 kdelibs4-dev=4:3.4.0-0pre3 
 .... with all the other packages you list on the line at the same time 
and it should work. 

Stephen

-- 
Debian the choice of a GNU generation.

GPG Public Key: http://users.eastlink.ca/~stephencormier/publickey.asc

Attachment: pgpvF7sYnZ6XG.pgp
Description: PGP signature


Reply to: