[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: favicons not displayed anymore

Am Donnerstag, 7. April 2005 14:01 schrieb Frans Pop:
> On Thursday 07 April 2005 13:35, Hendrik Sattler wrote:
> > Hmm, it worked before and I do not see any setting for konqueror that
> > could change that. Maybe you have something (not) installed and that
> > changes it? Do you get those libpng error messages?
> No, don't get those.
> I have:
> ii  libpng10-0     1.0.18-1       PNG library, older version - runtime
> ii  libpng12-0     1.2.8rel-1     PNG library - runtime
> Konqueror seems to depend on the second one.

I have the same. Just recognized that the latest upgrade made my /var go to 
100% :-(
I guess apt/dpkg would complain if something goes wrong because of this?

I reinstalled libpng12-0 and konqueror, even rebooted. Still this error:
libpng error: Read Error
konqueror: ERROR: Error in BrowserExtension::actionSlotMap(), unknown action : 
libpng error: Read Error

Calling konqueror with "strace -e open" reveals the following:
open("/var/tmp/kdecache-hendrik/favicons/www.debian.org.png", O_RDONLY|
libpng error: Read Error

Deleting all favicons there solved the issue. Still, konqueror/libpng shows 
here _extremely_ dumb behaviour: it sees that the file is broken but does not 
replace it :-(
And libpng could be a bit more verbose with its error messages, too. I'd 
expect _at_least_ the file name to be included in that dumb error message.

It now shows me the favicon for SourceForge.net but www.debian.org does not 
show the swirl :-(
However, Firefox shows it and it is present: http://www.debian.org/favicon.ico


Reply to: