[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Error compiling kdebase-3.4.0-0pre3



On April 7, 2005 07:27, Oliver Heins wrote:
> When compiling kdebase-3.4.0-0pre3 from source I get this
> error:
>
> In file included from libkiomedia_la.all_cpp.cpp:3:
> /home/build/kdebase-3.4.0/kioslave/media/mediaimpl.cpp: In
> member function `
>    bool MediaImpl::ensureMediumMounted(Medium&)':
> /home/build/kdebase-3.4.0/kioslave/media/mediaimpl.cpp:232:
> error: `
>    setInteractive' undeclared (first use this function)
> /home/build/kdebase-3.4.0/kioslave/media/mediaimpl.cpp:232:
> error: (Each
>    undeclared identifier is reported only once for each
> function it appears
>    in.)
> make[5]: *** [libkiomedia_la.all_cpp.lo] Error 1
> make[5]: Leaving directory
> `/home/build/kdebase-3.4.0/obj-i386-linux/kioslave/media'
> make[4]: *** [all-recursive] Error 1
> make[4]: Leaving directory
> `/home/build/kdebase-3.4.0/obj-i386-linux/kioslave/media'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory
> `/home/build/kdebase-3.4.0/obj-i386-linux/kioslave'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory
> `/home/build/kdebase-3.4.0/obj-i386-linux'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory
> `/home/build/kdebase-3.4.0/obj-i386-linux'
> make: *** [debian/stamp-makefile-build] Error 2
>
> I'm using pentium-builder to get optimized .debs and have
> set DEBIAN_BUILDARCH=pentiumpro.  Building used to work
> with kdebase-3.4.0-0pre2.

Are you building on top of kdelibs_3.4.0-0pre3 ? KDE is often utterly 
atrocious when it comes to maintaining compatibility. Also, what dbus and 
hal packages do you have installed?

Cheers,
Christopher Martin

Attachment: pgpWzyIg0WWmL.pgp
Description: PGP signature


Reply to: