[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Dependency problems with Sound.

On Monday 24 January 2005 09:06 pm, Paul wrote:
> Tim Folger wrote:
> > On Monday 17 January 2005 06:44 am, Alan Chandler wrote:
> >>Its probably my fault for using the kde packages from
> >>
> >>http://pkg-kde.alioth.debian.org/kde-3.3.2 ./
> >>
> >>BUT ...
> >>
> >>system notifications which were ogg files would not play, so I am
> >>attempting to do an upgrade of my debian unstable system.
> >>
> >>There seems to be a new "libflac6" attempting to be installed,
> >>which k3b needs, and which conflicts with libflac4.  This
> >> conflict is attempting to remove libflac4 and most of
> >> kde-multimedia.
> >>
> >>Any way round this?
> >>--
> >>Alan Chandler
> >
> > I had exactly the same problem. I finally solved it by manually
> > installing the kde-multimedia upgrade (apt-get update, then
> > apt-get install kde-multimedia). After that I was able to install
> > the remaining upgrades with the normal apt-get upgrade command
> > without removing all of kde. Once all the upgrades were
> > installed, I had to delete two files (knotify.eventsrc and
> > knotifyrc) from
> > ~/.kde/share/config. When I restarted kde I had system sounds
> > back as a normal user. I hope this works for you, too.
> I'm still having this problem, even after getting the latest
> updates installed.  It seems libflac and libvorbis are being held
> out due to a dependency problem with packages (akode, juk,
> kaudiocreator, kdemultimedia-kio-plugins) in kdemultimedia.  But,
> the maintainers announced the new versions on Jan 13.  Have they
> appeared in your mirror yet?  Which mirror are you using?  I've
> tried ftp.au, ftp,de, ftp.us so far, with no updates when I do
> apt-get install kdemultimedia.
> paul'

My apt sources are rather standard:

deb http://http.us.debian.org/debian unstable main contrib non-free
deb http://non-us.debian.org/debian-non-US unstable/non-US main 
contrib non-free

And I was able to update kde-multimedia. Maybe someone with more 
experience than I have can figure out what the problem is. 


Reply to: