[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE Update

On Thu, 13 Jan 2005 17:14:26 +0000
Richard Ibbotson <richard@sheflug.co.uk> wrote:

RI> Georg and Anders
RI> > > I'm wondering whether it's a good time to update my own machine
RI> > > to KDE 3.3.1 ?  Other one is that I don't know what to tell
RI> > > apt-get to do to update to 3.3.1.  Perhaps someone can help me
RI> > > with that ?
RI> >
RI> > apt-get update && apt-get upgrade
RI> Yes.  Been doing that some weeks :)  What I get is this every time
RI> for the past two weeks ...
RI> # apt-get upgrade
RI> Reading Package Lists... Done
RI> Building Dependency Tree... Done
RI> The following packages have been kept back:
RI>   amor ark artsbuilder atlantik atlantikdesigner bug-buddy capplets 
RI> capplets-data cupsys dcoprss digikam
RI>   ecasound2.2 eog epiphany-browser evolution eyesapplet
RI>   fifteenapplet 
RI> file-roller fireflier-client-kde
RI>   foomatic-gui gconf-editor gdm gedit gedit-common ggz-kde-games
RI>   gnome 
RI> gnome-about gnome-applets
RI> and about another 120 m/m of it in Konsole.  So, KDE is refusing to 
RI> update when I run upgrade.  Packages have been kept back.  Looks
RI> like it's just me and not someone else ?

Try dist-upgrade instead of upgrade -- that does a far better job of
finding extra packages that need to be installed. Basically if a
completely new package is needed, upgrade holds the package that
requires it, dist-upgrade offers to install the new package.


| James Tappin           | School of Physics & Astronomy |  O__    |
| sjt@star.sr.bham.ac.uk | University of Birmingham      | --  \/` |
| Ph: 0121-414-6462. Fax: 0121-414-3722                  |         |

Reply to: