[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing kde apps in a user directory


I have tried to install kmldonkey(compiled from source) to a separate 
directory named ~/kde-local in new debian sarge.

The problem is that I get an error when trying to access a function in 
kmldonkey which is implemented using a lib in ~/kde-local/lib/kde3.
It says: "Error loading the module"
I have added (after reading lots of good suggestions) the following lines to 
my .bashrc:

export KDEDIRS=/home/thomas/kde-local
export PATH=.:/home/thomas/kde-local/bin:$PATH

I also tried to use KDEDIR instead of KDEDIRS, adding LD_LIBRARY_PATH, etc. pp
helped also not. Executing "kde-config --path module" gives me the correct 
thomas@thomas:~$kde-config --path module

I just for fun copied the kcm* files from kde-local/lib/kde3 to  
~/.kde/lib/kde3 and run "kbuildsycoca --noincremental" and it worked.

Any hints what im doing wrong ?

Thanks for your help

Thomas Braun

Reply to: