[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libstdc++ dependencies

On Sat, May 08, 2004 at 02:50:34PM -0700, Craig Maloney wrote:
> It appears that many kde libraries (e.g. libkofficecore) debend on 
> GLIBCPP_3.2.2.  The dependencies for kdelibs4 show a dependence on 
> libstdc++5 (>= 1:3.3.3-1), and I have installed 1:3.3.3-6.  And 
> libstdc++5,1:3.3.3-6 owns /usr/local/lib/libstdc++.so.5.  A readelf on 
> this 
> file shows that it defines symbols such as:
>     37: 00057780   101 FUNC    WEAK   DEFAULT   11 somefunc@@GLIBCPP_3.2
> but no "@@GLIBCPP_3.2.2".

In unstable I get this:

ccheney@calc-amd64:~$ readelf -s /usr/lib/libstdc++.so.5.0.5  | grep 3.2.2
   461: 000a1154     4 OBJECT  WEAK   DEFAULT   15 _ZNSt24__default_alloc_te@@GLIBCPP_3.2.2
  3141: 00000000     0 OBJECT  GLOBAL DEFAULT  ABS GLIBCPP_3.2.2

So if there are no mentions of 3.2.2 in the testing version then the shlib
on libstdc++5 probably needs to be bumped.

I am cc:'ing the Debian GCC Maintainers so they can see this message.


Attachment: signature.asc
Description: Digital signature

Reply to: