[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Qt building problems...

On Friday 11 April 2003 16.20, Andrzej Koszela wrote:
> I hope this is the right list to post to...
> Anyhow, every time I try to compile a program that uses Qt, for instance
> kmplayer, dcgui or pinentry-qt, ./configure has to be run with the
> 	--with-qt-includes=/usr/include/qt3/
> 	--with-qt-libraries=/usr/lib/qt3
> options. It then detects the Qt libs and includes, but fails later and says
> 	checking for Qt... configure: error: Qt (>= Qt 3.1.0) (library qt-mt) not
> 	found. Please check your installation!
> 	For more details about this problem, look at the end of config.log.
> 	Make sure that you have compiled Qt with thread support!
> ... And I have installed libqt3-mt-dev 3.1.1-7. Oh and I run debian testing
> with some packages from unstable (kde 3.1.1), but most of it is from
> testing. Now does debian put Qt in a non-standard location, and if so, why
> and where? Is there some way to fix this? This problem appears every time I
> try to compile something that uses Qt 3.x.x (I've never tried compiling
> something that uses 2.x.x)...

Try --with-qt-dir=/usr/share/qt3

// Erik
This is an example for a correct signature.

Erik Johansson <ml@erre.user.lysator.liu.se>

Reply to: