[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE 3.05 to 3.1...

Hash: SHA1

Am Samstag, 8. März 2003 08:57 schrieb Ralf Nolden:
> On Samstag, 8. März 2003 08:05, Terry Gray wrote:
> > install kdesdk and kdelibs4-dev due to the following unsatisfied
> > dependencies:
> >
> > libasound2 (=0.9.0beta10a-3) (UNSATISFIED)
> > libmad0-dev  depends libmad0 (=0.14.2b-3) (UNSATISFIED)
> > libcupsys2-dev depends libcupsys2 (=1.1.14-3)(UNSATISFIED)
> > libogg-dev depends libogg0 (=1.0rc3-1)(UNSATISFIED)
> > libvorbis-dev depends libvorbis (=1.0rc3-1)(UNSATISFIED)
> You're using testing, not woody :-) The -dev packages always have to match
> the version that you used to link the package to, so there's nothing much
> you can do about. But about libasound2, hm, did you try apt-get -f install
> ? Which package is it that causes problems and requires that one ?

They don't have to match. The depends-line for kdelibs4-dev looks like this:
Depends: kdelibs4 (= 4:3.1.0-1woody2), kdelibs-bin (= 4:3.1.0-1woody2), 
libart-2.0-dev, libartsc0-dev, libcupsys2-dev, libfam-dev, libpcre3-dev

Even when using testing, there is not dependency on a specific version of e.g. 
libcupsys2-dev. I have testing here with your kdelibs4-dev installed and the 
following versions of the above packages:
ii  libasound2     0.9.0rc7-1     Advanced Linux Sound Architecture (libraries
ii  libmad0-dev    0.14.2b-4      MPEG audio decoder development library
ii  libcupsys2-dev 1.1.18-2       Common UNIX Printing System(tm) - developmen
ii  libogg-dev     1.0.0-1        Ogg Bitstream Library Development
ii  libvorbis-dev  1.0.0-1        Vorbis Library Development

libasound2 and libcupsys2-dev are recompiled from SID due to problems.
If he is using testing, he might have left-overs from woody because not all 
packages in testing have a higher version than woody (with proposed and 
security updates).


- -- 
Mein GPG-Key ist auf meiner Homepage verfügbar: http://www.hendrik-sattler.de
        oder über pgp.net

PingoS - Linux-User helfen Schulen: http://www.pingos.org
Version: GnuPG v1.2.1 (GNU/Linux)


Reply to: