[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Package epochs and broken upgrades



Hi all.  I've had a couple of instances of this problem land in my inbox
just this morning so I figured I'd send a general mailout in the hope of
reducing the problem.

Various unofficial package repositories have at various times used the
incorrect epochs in their package versions.  An epoch is the
highest-level test in determine what's an upgrade and what's a
downgrade; for instance, version 4:3.0.5a (with epoch 4:) is considered
newer than version 3.1.0 (which doesn't have an epoch, i.e., has epoch 0:).

Specifically, in some of the unofficial package repositories (including
the 3.0.x debs on kde.org I believe), *all* of the KDE packages have
been given epoch 4: although some are only supposed to have epoch 0: or
1:.  Affected packages include all of the kdesdk, kdeedu, kdeartwork and
kdeaddons packages (not sure what else).

This means that your system will *not* smoothly upgrade to the 3.1
packages that will be uploaded to sid.  In this case probably the
easiest solution is to remove all of the affected packages and then
reinstall them as you normally would in dselect or whatever package
management tool you use.

Perhaps I should just bite the bullet and put a 4: epoch on all of the
packages that are going into sid.  Though in general there have been so
many unofficial repositories in so many places by so many people that
we can't support smooth upgrades from all of them.  But anyway.  In the
meantime, if you're finding that dselect won't upgrade from your
unofficial 3.0.x or 3.1 version of ksomethingorother, please bear in
mind that this might be the problem.

Ben. :)

Attachment: pgpQi2tOquSAk.pgp
Description: PGP signature


Reply to: