[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

"Inconsistency detected by ld.so" error running KDE apps?

I posted this problem to debian-users and the debian-x lists earlier, but
got no responses, other than "I don't think this has anything to do with
XFree86" from Branden Robinson.

I haven't got any clues elsewhere, so thought I should try the KDE list

I am running Debian testing/sid, with XFree86 4.20 (installed from
unofficial debs), 
and kernel 2.4.19, on a Sony Vaio SR17 subnotebook. 

X works, as does wdm, but neither kdm nor gdm will start properly
(generally, I get a few brief flashes of the login screen before being sent
back to the command line).  

I can start wdm, and log in to wmaker. However, if I run _any_ KDE or Gnome
app (from a terminal in wmaker) I get the following error message:

	Inconsistency detected by ld.so: dynamic-link.h: 62:
	Assertion '! "bad dynamic tag"' failed

Generally, for KDE this message shows up immediately. Gnome apps may
get as far as putting a window up before they crash with the above.

These error messages first showed up after doing an upgrade from kde 2.2.2
to 3.01. I tried to downgrade, but this did not solve the problem. I have
again upgraded to the 3.0.3 debs from ftp.kde.org, but the problem persists.
It also occurred while running XFree86 4.1 from Woody.

The same error message is produced by running "startkde" from a shell. I
also get the same error message while dpkg attempts to configure a couple of
gnome packages (libpango and libgtk2, if I recall).

Anyone have any idea what is wrong here? I did a search for the above error,

but found very little, and nothing that helped solve the problem. Mostly
older postings 
to the kernel development list, with answers like "try this patch".

Has anyone ever seen this error message before? Anyone know what it means,
or what to do about it?

Apologize if this is not a KDE thing, but as I mentioned I have already
asked elsewhere and am at a loss.



Reply to: