[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libxml2 and libxslt1 are broken in kdelibs4?

Am Sonntag, 2. Juni 2002 04:14 schrieb Andy Saxena:

> > I'm rather new to debian but I want to update to kde 3.0.1.
> > I modified my sources.list and run apt-get update.
> > kdelibs4 is broken by UNSATISFIED dependencies of libxml2 (>=
> > 2.4.19-4) and libxslt1 (>= 1.0.16).
> > I can not add these by typing + nor remove by -
> >
> > Probably I have to remove conflicting kde 2.2.2 packages?
> libxml2 and libxslt1 should be upgradeable.

So I have to add a reference to the debian archive, like you 
noticed below to upgrade? I mention that I have the 8cd pack of 
woody also in the list!

> There are many KDE2 packages that conflict with the KDE3 ones,
> and these have to be removed, though some can be upgraded.

I résumé (reesumee), that will be done by apt-get automatically? 

> By the way, how can you apt-get update and then claim to be using
> aptitude? :-}

I ran apt-get update to update the database and after that I used 
aptitude as frontend. Aptitude shows me the unsatisfied 

> If you are used to using aptitude from the command line, you
> should check out aptitude's interactive interface.

If I type aptitude on the commandline an interactive sort of 
aptitude appears. What will happen if you'll do it? ;)

> > I want to use kde 2.2.2 and kde 3.0.1 next to each other (sorry
> > about my english) choosen by kdm. There will not be a serious
> > problem with that intention?
> You cannot do this with the debs from geniussystems. Kdelibs4
> conflicts with kdelibs3!

So the maintainers of the experimental kde3 debs didn't 
planed/provide the possibility to choose between kdeX and kde3?
I saw the following descriptions to use different kde-versions next 
to each other:


> > My sources.list looks like:
> I don't see a reference to the debian archive. You need to add
> one. Libxml2 and libxslt1 can be found there. 

Thank you. I will add that line.

> In fact, I wouldn't
> be surprised if you see the two packages listed under "Obsolete"
> in aptitude.
> > ps:
> > under suse 7.3 it's suggested to do the following steps:
> >
> > 1. removing old xml packages
> > 2. install new xml packages
> > 3. install several needed libs
> > 4. remove disturbing packages
> > Q: Got it to do something with the broken kdelibs4 (in other
> > words: is it the same or a similar problem?) Are similar things
> > neccessary with woody? If yes: How to do it in debian
> Eek! No RPMs please, we are Debian :-}. 

I asked only for a similar solution for debian, because I compared 
the xml point of that description with the unsatisfied dependencies 
who aptitude has shown me i.e. I want to handle the dependencies 
with apt-get or dpkg of course!

> Debian automatically
> handles dependency issues. If two packages conflict, you will
> know it firsthand.

I summarize: so there left nothing to be done manual by hand? I can 
solve all dependencies just by add the following lines beneath the 
other references in my sources.list (I mention to have already the 
lines for the 8cd distri, and that I new to debian):

deb http://non-us.debian.org/debian-non-US stable/non-US main 
contrib non-free
deb ftp://debian.uni-essen.de/debian/ potato main contrib non-free

deb http://ftp.de.debian.org/debian potato main
deb-src http://ftp.de.debian.org/debian potato main

I use woody can I change them like this?:

deb http://non-us.debian.org/debian-non-US testing/non-US main 
contrib non-free
deb ftp://debian.uni-essen.de/debian/ woody main contrib non-free

deb http://ftp.de.debian.org/debian woody main
deb-src http://ftp.de.debian.org/debian woody main


I summarize also that it is impossible for this moment to 
use kde2 and 3 together and choose them with kdm??

Thank you


To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: