[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libxml2 and libxslt1 are broken in kdelibs4?


I'm rather new to debian but I want to update to kde 3.0.1.
I modified my sources.list and run apt-get update.
kdelibs4 is broken by UNSATISFIED dependencies of libxml2 (>= 
2.4.19-4) and libxslt1 (>= 1.0.16). 
I can not add these by typing + nor remove by -

Probably I have to remove conflicting kde 2.2.2 packages?

How can I solve that, or isn't that a serious issue.
I want to use kde 2.2.2 and kde 3.0.1 next to each other (sorry 
about my english) choosen by kdm. There will not be a serious 
problem with that intention?

My sources.list looks like:
# primary mirror
deb http://kde3.geniussystems.net/debian ./
deb http://kde.debian.co.nz/debian ./
# mirrors all kde debs
deb http://kde.ping.uio.no/i386 ./

# KDE 3.0.1 Grundpakete
# deb http://kde3.geniussystems.net/debian ./
# Noch mehr Pakete
deb http://people.debian.org/~bab/kde3 ./
# KDevelop 2.1.1 for KDE 3.0
deb http://people.debian.org/~njordan kde3.0/
# kdegames 3.0.1
deb http://people.debian.org/~schepler kdegames/

# official liquid
deb  http://arachni.kiwi.uni-hamburg.de/~harlekin ./binary-i386/

Any suggestion is appreciate.



under suse 7.3 it's suggested to do the following steps:

1. removing old xml packages

rpm -e libxslt-devel
rpm -e libxslt
rpm -e libxml2-devel
rpm -e --nodeps libxml2

2. install new xml packages

rpm -Uvh libxml2-2.4.19-1.i386.rpm libxslt-1.0.14-1.i386.rpm

3. install several needed libs

4. remove disturbing packages

rpm -e  kdenetwork-devel
rpm -e kdenetwork

Q: Got it to do something with the broken kdelibs4 (in other words: 
is it the same or a similar problem?) Are similar things neccessary 
with woody? If yes: How to do it in debian

To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: