[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kamera + USB permissions

On Monday 18 March 2002 12:33 pm, Jens Benecke wrote:
> On Mon, Mar 18, 2002 at 02:00:40AM +0200, Jarno Elonen wrote:
> > I just tried Kamera after quite a long time and it actually worked.
> > Thank you!  It isn't, however, very feasible to use because the device
> > file is owned by root: you always have to change its permissions
> > manually before starting Kamera as a non-root user.  I found a small
> > daemon called usb-perms (and packaged it into a .deb
> That's what DEVFS (device file system) is for. If you use 2.4 kernels
> and have devfs compiled in, the /dev tree will be maintained as an 'in
> memory' file system, with things like nodes, permissions, etc. (also for
> "not yet existing" nodes) saved in /etc/devfsd/perms and associated
> files.

But USB devices are not in the /dev tree..  they are in proc.  They show up 
in /proc/bus/usb/   The few usb device files in /dev/ are for use with 
particular drivers (the usb-printers, etc) 

So far, the only utility that handles usb permissions is usb-perms  


Reply to: