[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lost icons in some KDE apps

Hash: SHA1

On Wednesday 02 January 2002 08:39 am, Wolfgang Ratzka wrote:
> > It seems that the libpng has been changed in a major way, and is
> > therefore affecting anything that is compiled against it.
> Is this really true? Both versions of libpng can co-exist on a
> system, and an application that was linked against one of them will
> automatically pick the right version.
> The problem with the kde apps was that they were linked against the
> old version whereas libqt was changed to be linked against the newer
> one. So loading a kde app loaded both versions of libpng, which
> cannot work.

Here is what I get when I start kmail from a Xterm. Woody with latest 
KDE from Sid.

libpng error: Incompatible libpng version in application and library
libpng warning: Application was compiled with png.h from libpng-1.0.12
libpng warning: Application  is  running with png.c from libpng-1.2.1

- -- 
Greg Madden
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org


Reply to: