[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: artsd is segfaulting with alsa drivers

On Monday 09 July 2001 17:23, Stephan Jaensch wrote:
> Same here. Wild guess: artsd is compiled against alsa-0.5. I never managed
> to compile artsd against alsa-0.9 myself but against alsa-0.5 worked fine
> so I think the KDE team has not ported artsd to alsa-0.9 yet.

I was thinking the same thing.

> Workaround: Compile alsa with oss-emulation support and set the sound I/O
> method under Sound->Sound Server->Sound I/O in the control center to "Open
> Sound System".

Thanks for the workaround. Unfortunately it doesn't work for me. I tried this 
before with $artsd -a oss and tried it through the control panel as you 
suggested. I get a dialog box that says 'cpu overload, aborting', WTF!

Since I have just started using alsa on this machine and the workaround does 
not seem to work, do you think it would be best to downgrade to alsa-0.5 or 
wait for artsd to be compiled with 0.9 support (if this is in fact the 
issue)? Also, maybe someone on the list has another idea?

Joseph Schlecht

Reply to: