[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: make-jpkg doesn't provide default-jre-headless

On 18 February 2013 17:38, Emmanuel Bourg <ebourg@apache.org> wrote:

> Could you give a try at this version of java-package please?
> https://github.com/ebourg/java-package
> I added the missing dependencies for Ubuntu.

./make-jpkg: line 220: get_architecture: command not found

Looks like common.sh is missing from yours (and from the current
version of Cédric's). Or I did something wrong (I just downloaded the
zip, unzipped it and ran ./make-jpkg in the directory.)

However! I took the old version of Cédric's, and added your changes to
the Provides: lines. I built a deb from the Oracle download of 6u39. I
then tried "sudo apt-get install tomcat6" ... and it tried to pull in
openjdk-6 related packages.

The other problem is that Oracle no longer distributes Java 7 as a bin
archive - it now distributes it as a .rpm or as a .tar.gz - a tarball
of the jdk1.7.0_13/ directory tree, and make-jpkg has no idea what to
make of this. I see we have work ahead of us ...

- d.

Reply to: