[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IcedTea - a first step towards OpenJDK

Matthias Klose wrote:
peter green schrieb:
IcedTea is a temporary fork of OpenJDK which allows building with a free
toolchain and adding/replacing code which is not yet available under a
license. First deb Packages for amd64 and i386 are available at

 deb http://people.ubuntu.com/~doko/ubuntu/
<http://people.ubuntu.com/%7Edoko/ubuntu/> gutsy/
 deb-src http://people.ubuntu.com/~doko/ubuntu/
<http://people.ubuntu.com/%7Edoko/ubuntu/> gutsy/

Although the packages are built on gutsy, they are installable on sid
as well.
Unfortunately while the binary may be installable on sid the source
doesn't seem to be buildable on it.

firstly I needed to do some tweaks to build-deps were needed to provide
alternatives to ubuntu only packages. I added xbase-clients as an
alternative for xprop and libxul-dev as an alternative for firefox-dev.
wget was also missing from the build-deps.

ok, except wget should not be part of the b-d's, if the zip file already exists.
The configure script checks for it and errors if it is not there.
However even with those things fixed it still doesn't build for me, in a
64 bit chroot on a 64 bit box and a 32 bit chroot on a 32 bit box I get
the following errors

find rt -name '*.java' | sort > rt-source-files.txt
nowarn -g -d lib/rt -bootclasspath '' -source 1.6 \
/classes:generated:jce \
make[1]: nowarn: Command not found

ok, please install ecj by hand; that may be the dependency error (ecj-gcj not
depending on ecj).
ok that seems to fix the 64 on 64 case. The 32 on 32 case is still building (my 32 bit box isn't very fast)
and in a 32 bit chroot on a 64 bit host I got the following error

did you set the 32bit personality before entering the chroot? If not try to use
schroot which does this for you (if correctly configured).

no, I've never had to for building debian packages before and i've no idea how to do it either. I really would rather avoid switching to a soloution like schroot if I can. Is there a way I can set it manually? (googling for linux kernel personality brought up mostly info on the linux compatibility features in sco unix)

Reply to: