[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: IcedTea - a first step towards OpenJDK

peter green schrieb:
>> IcedTea is a temporary fork of OpenJDK which allows building with a free
>> toolchain and adding/replacing code which is not yet available under a
>> free
>> license. First deb Packages for amd64 and i386 are available at
>>  deb http://people.ubuntu.com/~doko/ubuntu/
>> <http://people.ubuntu.com/%7Edoko/ubuntu/> gutsy/
>>  deb-src http://people.ubuntu.com/~doko/ubuntu/
>> <http://people.ubuntu.com/%7Edoko/ubuntu/> gutsy/
>> Although the packages are built on gutsy, they are installable on sid
>> as well.
> Unfortunately while the binary may be installable on sid the source
> doesn't seem to be buildable on it.
> firstly I needed to do some tweaks to build-deps were needed to provide
> alternatives to ubuntu only packages. I added xbase-clients as an
> alternative for xprop and libxul-dev as an alternative for firefox-dev.
> wget was also missing from the build-deps.

ok, except wget should not be part of the b-d's, if the zip file already exists.

> However even with those things fixed it still doesn't build for me, in a
> 64 bit chroot on a 64 bit box and a 32 bit chroot on a 32 bit box I get
> the following errors
> find rt -name '*.java' | sort > rt-source-files.txt
> nowarn -g -d lib/rt -bootclasspath '' -source 1.6 \
>          -sourcepath
> rt:openjdk/j2se/src/share/classes:openjdk/j2se/src/solaris
> /classes:generated:jce \
>          @rt-source-files.txt
> make[1]: nowarn: Command not found

ok, please install ecj by hand; that may be the dependency error (ecj-gcj not
depending on ecj).

> and in a 32 bit chroot on a 64 bit host I got the following error

did you set the 32bit personality before entering the chroot? If not try to use
schroot which does this for you (if correctly configured).

Reply to: