[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: arachnophilia undo/redo

Henning thanks for the help. I need to go and do some more research now. Just to quickly tell you what is eliminated:

Henning Sprang wrote:
- make sure you are not using a free non-sun java implementation
accidentally that might behave not 100% exactly as the sun
implementation the program seems to be tested against. Check to ouput of
java -version to see which java is on your default path.

I am definitely using the packaged SUN versions from non-free. All my versions of java are:

sudo update-alternatives --config java
+        1    /usr/lib/jvm/java-6-sun/jre/bin/java
         2    /usr/bin/gij-4.1
         3    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
        4    /usr/lib/jvm/ia32-java-6-sun/jre/bin/java
         5    /usr/lib/jvm/ia32-java-1.5.0-sun/jre/bin/java

Debian is 'pure 64' although it runs 32 bit emulation java VM as well. Using them didn't solve the problem. I don't have a chroot or a full 32 bit system to try this on so the possibility of it being a 64 bit problem will have to go unexplored for a while.

- you could try and see if the problem also exists on a clean Etch
install. Actually, I just tried it on Etch and Ubuntu Dapper with the
package sun-java5-bin , and I don't see it happening - undo works fine
here. (on 32 bit)

That's good information - I will try downgrading the java packages all the way to etch as my first experiment.
- you could try to delete/recreate any java related config files you
have on your system from scratch, and see if that helps.
And that will be my next experiment. There are likely looking configuration files in /etc/$JAVAVERSION.
java(but I am not 100% sure). You could instead try to get a Java tar.gz
from Sun of the same version as the debian packages provide it, install
it, and see what happens.
If I get that far I'll try that as my third experiment.
- lastly, you could ask Paul Lutus about which java methods are used for
the undo function you are missing, and try to get nearer to the lines of
code in either arachnophilia or the java implementation you use to help
track down the problem. Maybe arachnophilia has a unit test suite, and
you can try if these tests run fine.
As arachnophilia is not free and seems not to come with sources, your
possibilities to check the problem seem very limited to me.

Yes I was wondering about this. Arachnophilia was the bees-knees when I was a windows user in 1999 but I am realising it has this limitation over all the great gpl software I use now I have escaped to the world of GNU/Linux.
- Depending on how much time and work you want to invest, you might also
just try using bluefish, another nice html editor :)
I have tried Bluefish not so long ago - I didn't mind it. One thing that draws me to Arachnophilia is its simplicity for html, css and javascript work. Now I am actually finding my fallback - the latest version of gedit - is getting me almost as productive as I can be with Arachnophilia. But Arachnophilia is unparalleled as a cross-platform tool for training people in html coding. I have been designing for a while a course based around Arachnophilia and GIMP.

thanks again for the input.  I have a few good lines of research now.

Graham E

Reply to: