[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

arachnophilia undo/redo

I am running debian sid pure 64

I'm experiencing a problem with Arachnophilia which runs on a java VM. The problem is that the undo and redo functions don't work (whether via clicking on icons, using menus or key combinations). There is just an error beep and no other effect whenever undo/redo is attempted. There is also nothing written to the Arachnophilia error log. Other than this problem Arachnophilia runs faultlessly.

I have tried a range of scenarios:
Arachnophilia 5.3 running on
sun-java6-jre 6-00-2
sun-java5-jre 1.5.0-11-1
sun-java5-jre 1.5.0-12-1
Arachnophilia 5.2 running on
sun-java6-jre 6-00-2
sun-java5-jre 1.5.0-11-1
sun-java5-jre 1.5.0-12-1

I also tried the use of the ia32-sun-java5/6-bin versions.

Lastly I tried downgrading java-common from 0.26 (unstable/sid) to etch-stable version (0.25) and also running Arachnophilia/java as root. Nothing worked.

Paul Lutus, the programmer of Arachnophilia, just responded to my bug report saying what I already knew : this is unlikely to be an Archnophilia problem. He says he has around 1/2 million installations and no similar reports.

But the other thing is : this is unlikely to be a sun-java problem as I have had Archnophilia undo/redo work fine on Fedora Core 4 - 64 running on sun 5.0 jre. Paul Lutus has also had the identical installation working fine (possibly on 32-bit FC4).

Calling for:
hints on what to do/ possible causes/fixes...

Hints on which package to file a bug against (the latest jre?  1.5 AND 1.6?)

I am temporarily subscribed to this list to see any replies - I really want to resolve this issue and would appreciate any help I find here.

Graham E

Reply to: